Resolved
We're seeing the backlog clear, and emails arriving in inbox! We'll continue to keep an eye on the outbound queue.
Monitoring
Postmark shipped a fix, and are recovering from the incident! We're seeing the backlog start to clear, and we'll continue monitoring.
Identified
We're currently rerouting traffic to other ESPs. This includes newsletters on the Buttondown domain, and newsletters with managed custom domains, and transactional emails.
Newsletters with a manual sending domain on Postmark servers are still impacted by this outage.
Investigating
We're monitoring an incident on Postmark, that's causing a delay for outbound newsletters and transactional emails.