Resolved
The fix has been stable, and we've had confirmation from Authors that images are working as expected now.
Marking this resolved ✅
Monitoring
We've moved traffic off the impacted Cloudflare infrastructure, and we're seeing images working as expected again. (Give your browser a good refresh!)
We'll continue to monitor for any lingering issues.
Identified
We've learned that this image issue is related to an ongoing incident with Cloudflare files. We're continuing to monitor the situation and we'll update when we have more information.
Investigating
We're currently investigating reports that images are not loading in the Editor, Archives and Emails.