Back to overview
Degraded

Author-facing app failing to complete requests

Jan 17 at 09:21pm EST
Affected services
buttondown.com

Resolved
Jan 17 at 09:26pm EST

As written above, we've since recovered from the incident.

Created
Jan 17 at 09:21pm EST

From approximately 12:47pm EST to 2:15pm EST, most API requests coming from the author-facing app failed with a 400 error.

This occurred because we rolled out a change to our routing and formatting of those requests; amongst other benign changes, we inadvertently changed the formatting of the HTTP method (GET, POST, etc.) of outgoing requests from uppercase to lowercase (get, post, etc.). This change was tested and passed both our continuous integration and manual testing; however, Heroku (our cloud infrastructure provider) does not support this formatting for HTTP methods, and rejected all inbound requests.

Once we discovered the issue, we rolled back the deployment and rolled forward a change to correctly capitalize those methods.