Back to overview
Degraded

Delays in email sending; custom domain registration degraded

Jun 10 at 10:32am EDT
Affected services
Backlog

Resolved
Jun 11 at 01:30am EDT

The incident is now resolved, and Heroku is back online. (HugOps to their team!)

All services are operational, and Buttondown emails are being sent without delay.

Updated
Jun 10 at 06:00pm EDT

We're seeing improvements for this ongoing incident:

- Previously delayed emails have now been sent
- Our backlog is clearing in a timely manner
- New custom hosting domains are connecting as expected

But as Heroku is still reporting this as an active outage, we're continuing to monitor.

Created
Jun 10 at 10:32am EDT

Our upstream hosting provider, Heroku, is experiencing an ongoing outage. As a result:

  • We are unable to scale up our servers to match fluctuations in the number of emails our system is sending. This means that emails may sit in queue and take longer to send out — but they will eventually send without any intervention necessary.
  • We are unable to register new custom domains for archives.

All other areas of Buttondown are unaffected.

  • Emails will eventually send without any intervention, but may take longer to do so. If you're waiting on an email to go out, please do not attempt to send it a second time.
  • Custom domains that are already set up will work as usual.
  • Custom domain setup for archives will work again after Heroku's incident is closed.