App is currently unavailable
Resolved
Jul 21 at 09:19am EDT
We've addressed the root cause of the issue, and our systems are now fully operational.
We experienced a sudden increase in load that overwhelmed our previous process model, making it difficult for the system to recover gracefully once under stress.
To resolve this, we’ve shifted our load balancing approach and scaled up, which allows us to run multiple concurrent processes per instance. This not only improves overall capacity and responsiveness but also lets us restart individual processes without placing stress on the entire system - increasing resilience moving forward.
Affected services
Updated
Jul 21 at 08:07am EDT
The service has been restored, but there may still be intermittent errors and delays in loading the application. We're continuing to investigate the root cause and monitor the status of the application.
Affected services
Created
Jul 21 at 07:35am EDT
We're currently investigating reports that the web app is unavailable. This is impacting the Dashboard, login and hosted archives.
Affected services