Back to overview
Degraded

Cloudflare is experiencing an outage

Nov 18 at 09:29am EST
Affected services
buttondown.com

Resolved
Nov 18 at 11:13am EST

Cloudflare has identified the root cause of the incident and is currently recovering.

Created
Nov 18 at 09:29am EST

Our CDN is currently impacted by the wide-scale Cloudflare outage (https://www.cloudflarestatus.com/). Additionally, some of our vendors are impacted, too, such as our primary customer service support center.

We will update this ticket if their specific failures bleed over into anything that may impact you significantly. In the meantime, you may experience issues with assets loading or delayed support responses.